Array Manipulation C++ Solution
Starting with a 1-indexed array of zeros and a list of operations, for each operation add a value to each of the array element between two given indices, inclusive. Once all operations have been performed, return the maximum value in your array.
For example, the length of your array of zeros . Your list of queries is as follows:
a b k
1 5 3
4 8 7
6 9 1
Add the values of between the indices and inclusive:
index-> 1 2 3 4 5 6 7 8 9 10
[0,0,0, 0, 0,0,0,0,0, 0]
[3,3,3, 3, 3,0,0,0,0, 0]
[3,3,3,10,10,7,7,7,0, 0]
[3,3,3,10,10,8,8,8,1, 0]
The largest value is after all operations are performed.
Function Description
Complete the function arrayManipulation in the editor below. It must return an integer, the maximum value in the resulting array.
arrayManipulation has the following parameters:
- n - the number of elements in your array
- queries - a two dimensional array of queries where each queries[i] contains three integers, a, b, and k.
Input Format
The first line contains two space-separated integers and , the size of the array and the number of operations.
Each of the next lines contains three space-separated integers , and , the left index, right index and summand.
Constraints
Output Format
Return the integer maximum value in the finished array.
Sample Input
5 3
1 2 100
2 5 100
3 4 100
Sample Output
200
Explanation
After the first update list will be 100 100 0 0 0
.
After the second update list will be 100 200 100 100 100
.
After the third update list will be 100 200 200 200 100
.
The required answer will be .
Solution in C++
Approach 1.
#include <iostream>
using namespace std;
const int NMAX = 1e7+2;
long long a[NMAX];
int main()
{
int n, m;
cin >> n >> m;
for(int i=1;i<=m;++i){
int x, y, k;
cin >> x >> y >> k;
a[x] += k;
a[y+1] -= k;
}
long long x = 0,sol=-(1LL<<60);
for(int i=1;i<=n;++i){
x += a[i];
sol = max(sol,x);
}
cout<<sol<<"\n";
return 0;
}
Approach 2.
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<assert.h>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
#include<map>
#include<set>
#define MAX(a,b) ((a)>(b)?(a):(b))
#define MIN(a,b) ((a)<(b)?(a):(b))
#define F first
#define S second
#define mp make_pair
#define pb push_back
#define pp pair<ll,ll>
#define INF 2000000000
#define ll long long
using namespace std;
const ll N=10000015;
ll a[N],n,m,i,j,x,y,k,ans;
int main()
{scanf("%lld%lld",&n,&m);
for(i=1;i<=m;i++){
scanf("%lld%lld%lld",&x,&y,&k);
a[x]+=k;
a[y+1]-=k;
}
for(i=1;i<=n;i++)a[i]+=a[i-1],ans=MAX(ans,a[i]);
cout<<ans<<endl;
return 0;
}